Archivo para 16 mayo 2008

Manejo de Fechas en Excel

Mucho que escribir y muy poco tiempo para hacerlo, después de mucho rato de no escribir volvemos con algo con el que me di topes en su momento.

Muchos como yo, nos hemos preguntado alguna vez, como manejar adecuadamente las fechas en excel, por ejemplo los aniversarios, sobre todo cuando no cuentas con el software adecuado que te ayude a hacerlo en automático, pero para que llevar un control de aniversarios? en mi caso, llevar el control estricto de aniversarios de los empleados según la fecha en que ingresan a laborar con nosotros, y por consecuencia, presentar la modificación de salario ante el Instituto Mexicano del Seguro Social.

Vamos a ver algunos ejemplos que podemos usar, finalmente ustedes decidirán cual se adapta mas a sus necesidades.

PRIMER METODO

El mas fácil, y seguramente lo haz echo es mediante una resta, supongamos que en la celda A1 tienes la fecha de hoy 29/04/2008 y en la celda A2 la fecha de ingreso 10/04/2005, en la celda A3 haces la resta =A1-A2, el resultado es algo así según la región y configuración de tu pc 19/01/1903 00:00,

Resultado mediante una resta

 Para verlo en formato de número, vamos a formato de celda->personalizada->en Tipo: pones A como en la siguiente imagen:

Vista de numero mediante formato

El método anterior lo descarté seguramente al igual que ustedes, ya que el valor que vemos es solo el formato que le hemos dado, el valor real de la celda es 1115 (copiar y pegado especial valores en otra celda), y no me sirve para otras operaciones que tengo que hacer con el año obtenido.

SEGUNDO METODO

El siguiente método es con una formula bastante larga, pero más eficaz, aquí nos haremos bolas si tratamos de explicar lo que hace la fórmula, mejor copien el ejercicio en una hoja de excel y miren el funcionamiento.

Usemos los mismos datos del ejemplo anterior, en la celda A1 la fecha de hoy 29/04/2008 y en la celda A2 la fecha de ingreso 10/04/2005.

En la celda A3 obtenemos los años cumplidos:
=SI(MES(A2)>MES(A1),AÑO(A1)-AÑO(A2)-1,SI(DIA(A2)>DIA(A1),AÑO(A1)-AÑO(A2)-1,AÑO(A1)-AÑO(A2)))

En la Celda A4 obtenemos los meses cumplidos:
=SI(MES(A2)>MES(HOY()),12-ABS(MES(A2)-MES(A1)),SI(MES(A2)<MES(A1),MES(A1)-MES(A2),SI(DIA(A2)>DIA(A1),11,1)))

En la celda A5 obtenemos los días cumplidos:
=ABS(SI(DIA(A2)>DIA(A1),HOY(),DIA(A2)-DIA(A1)))

Resultado

TERCER METODO

Por ultimo, el que ahora estoy usando y el cual recomiendo es el siguiente, usamos los mismos datos, solo cambiamos las formulas:

En la celda A3 obtenemos los años cumplidos:
=SIFECHA(A2,A1,"y")

En la Celda A4 obtenemos los meses cumplidos:
=SIFECHA(A2,A1,"ym")

En la celda A5 obtenemos los días cumplidos:
=SIFECHA(A2,A1,"md")

Como podemos ver nos da el mismo resultado:

Los primeros dos argumentos de la formula son la fecha de hoy y la fecha de alta, los otros argumentos para esta función son:
“y” Año
“m” Total de Meses
“d” Total de Días
“ym” Meses que aún no hacen un año
“md”  Días que aún no hacen un mes

No solo sirve para saber cuantos días, meses o años han pasado, también lo podemos usar para saber cuantos días, meses o años faltan para algún evento, por ejemplo, si queremos saber cuantos días faltan para las Olimpiadas Beijing 2008:

A1 Fecha de Apertura 08/08/2008
A2 =hoy(), o sea 29/04/2008
A3 =SIFECHA(A2,A1,”d”)

Otros ejemplos para el manejo de fechas lo podemos encontrar en la página de Mocosoft http://support.microsoft.com/kb/214094/es


a

mayo 2008
L M X J V S D
« Ene   Jul »
 1234
567891011
12131415161718
19202122232425
262728293031  

Estadisticas

  • 1,276,685 hits